System Requirements

Minimum Hardware and Software Requirements for Moodle Course Interaction 

Students must have access to a broadband Internet connection, a personal computer manufactured within the last three years. Students taking online or blended courses will also need a USB Headset (the built-in microphone and speakers of a computer is not sufficient) and a USB Webcam (if one is not built into the computer). 

PCs: 

• Access to high-speed network connection (not dial-up, i.e., cable, dsl, etc.) 
• Processor: Pentium IV 3.0 Ghz / equivalent or better processor (dual core processor recommended) 
• Operating System: Windows Vista Service Pack 2, Windows 7 with all current updates installed (updates available at http://update.microsoft.com) 
• Memory: 2+ Gigabytes RAM Memory 
• Hard drive: 120 Gigabyte 
• Sound card and speakers 
• Headset with microphone or audio recordable microphone that plugs into your sound card (not a USB connection) 
• Monitor with 1024 x 728 pixel resolution or better 


• Software - install latest versions unless otherwise specified: 
  - Internet Browser: Chrome / Firefox / Internet Explorer 8 or greater
  - Current anti-virus software 
  - Microsoft Word 2003 or newer (or Word-format compatible word processor) 
  - Java/JRE: http://java.sun.com/javase/downloads/index.jsp 
  - Adobe Flash Player: http://get.adobe.com/flashplayer/ 
  - Adobe Reader: http://get.adobe.com/reader 
  - QuickTime: http://www.apple.com/quicktime/download/  

Mac OS X, GNU/Linux and other operating systems. The interface is translated into many languages.

  - Zoom Video Conferencing:  https://www.zoom.us/

Macs:   

• Access to high-speed network connection (not dial-up, i.e., cable, dsl, etc.) 
• Processor: PowerPC G4 or Intel 
• Operating System: OS X 10.4.9 
• Memory: 2+ Gigabytes RAM Memory 
• Hard drive: 120 Gigabyte 
• Sound card and speakers 
• Headset with microphone or audio recordable microphone that plugs into your sound card (not a USB connection) 
• Monitor with 1024 x 728 pixel resolution or better 
• Software - install latest versions unless otherwise specified: 

  -  Internet Browser: Chrome / Firefox / Internet Explorer 8 or greater 
  -  Zoom Video Conferencing:  https://www.zoom.us/

Last modified: Monday, 20 March 2017, 9:43 AM